Menu

Star on GitHub · 3.3k

CVE-2015-10094

2.4 · LOW

A vulnerability was found in Fastly Plugin up to 0.97 on WordPress.

Published Mar 6, 2023CWE-79EPSS 0.55%

Overview

CVE-2015-10094 is a low-severity vulnerability. It was published on March 6, 2023 and has a CVSS 3.1 base score of 2.4 (LOW).

This vulnerability has a CVSS 3.1 base score of 2.4, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2015-10094?

CVE-2015-10094 is a low-severity vulnerability. It was published on March 6, 2023 and has a CVSS 3.1 base score of 2.4 (LOW).

How severe is CVE-2015-10094?

This vulnerability has a CVSS 3.1 base score of 2.4, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2015-10094?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2015-10094?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2015-10094 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2015

View all
LiveWatch live →