Menu

Star on GitHub · 3.4k

CVE-2017-20017

6.3 · MEDIUM

A vulnerability, which was classified as critical, has been found in The Next Generation of Genealogy Sitebuilding up to 11.1.0.

Published Jun 8, 2022CWE-89EPSS 0.62%

Overview

CVE-2017-20017 is a medium-severity vulnerability. It was published on June 8, 2022 and has a CVSS 3.1 base score of 6.3 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

A vulnerability, which was classified as critical, has been found in The Next Generation of Genealogy Sitebuilding up to 11.1.0. This issue affects some unknown processing of the file /timeline2.php. The manipulation of the argument primaryID leads to sql injection. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 11.1.1 is able to address this issue. It is recommended to upgrade the affected component.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2017-20017?

CVE-2017-20017 is a medium-severity vulnerability. It was published on June 8, 2022 and has a CVSS 3.1 base score of 6.3 (MEDIUM).

How severe is CVE-2017-20017?

This vulnerability has a CVSS 3.1 base score of 6.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2017-20017?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2017-20017?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2017-20017 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2017

View all
LiveWatch live →