Menu

Star on GitHub · 3.4k

CVE-2020-11002

8.0 · HIGH

dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability.

Published Apr 10, 2020CWE-74EPSS 5.17%

Overview

CVE-2020-11002 is a high-severity vulnerability. It was published on April 10, 2020 and has a CVSS 3.1 base score of 8.0 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.0, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2020-11002?

CVE-2020-11002 is a high-severity vulnerability. It was published on April 10, 2020 and has a CVSS 3.1 base score of 8.0 (HIGH).

How severe is CVE-2020-11002?

This vulnerability has a CVSS 3.1 base score of 8.0, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2020-11002?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2020-11002?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-11002 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2020

View all
LiveWatch live →