Menu

Star on GitHub · 3.3k

CVE-2020-15150

9.0 · CRITICAL

There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function.

Published Sep 1, 2020CWE-94EPSS 3.31%

Overview

CVE-2020-15150 is a critical-severity vulnerability. It was published on September 1, 2020 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2020-15150?

CVE-2020-15150 is a critical-severity vulnerability. It was published on September 1, 2020 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

How severe is CVE-2020-15150?

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2020-15150?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2020-15150?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-15150 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2020

View all
LiveWatch live →