Menu

Star on GitHub · 3.3k

CVE-2020-15185

2.2 · LOW

In Helm before versions 2.16.11 and 3.3.2, a Helm repository can contain duplicates of the same chart, with the last one always used.

Published Sep 17, 2020CWE-74EPSS 0.88%

Overview

CVE-2020-15185 is a low-severity vulnerability. It was published on September 17, 2020 and has a CVSS 3.1 base score of 2.2 (LOW).

This vulnerability has a CVSS 3.1 base score of 2.2, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

In Helm before versions 2.16.11 and 3.3.2, a Helm repository can contain duplicates of the same chart, with the last one always used. If a repository is compromised, this lowers the level of access that an attacker needs to inject a bad chart into a repository. To perform this attack, an attacker must have write access to the index file (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 3.3.2 and 2.16.11. A possible workaround is to manually review the index file in the Helm repository cache before installing software.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2020-15185?

CVE-2020-15185 is a low-severity vulnerability. It was published on September 17, 2020 and has a CVSS 3.1 base score of 2.2 (LOW).

How severe is CVE-2020-15185?

This vulnerability has a CVSS 3.1 base score of 2.2, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2020-15185?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2020-15185?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-15185 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2020

View all
LiveWatch live →