Menu

Star on GitHub · 3.3k

CVE-2020-15187

3.0 · LOW

In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used.

Published Sep 17, 2020CWE-74EPSS 1.52%

Overview

CVE-2020-15187 is a low-severity vulnerability. It was published on September 17, 2020 and has a CVSS 3.1 base score of 3.0 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.0, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack.

To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2.

As a possible workaround make sure to install plugins using a secure connection protocol like SSL.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2020-15187?

CVE-2020-15187 is a low-severity vulnerability. It was published on September 17, 2020 and has a CVSS 3.1 base score of 3.0 (LOW).

How severe is CVE-2020-15187?

This vulnerability has a CVSS 3.1 base score of 3.0, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2020-15187?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2020-15187?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-15187 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2020

View all
LiveWatch live →