CVE-2020-26231
5.2 · MEDIUMOctober is a free, open-source, self-hosted CMS platform based on the Laravel PHP Framework.
Overview
CVE-2020-26231 is a medium-severity vulnerability. It was published on November 23, 2020 and has a CVSS 3.1 base score of 5.2 (MEDIUM).
This vulnerability has a CVSS 3.1 base score of 5.2, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.
Technical description
October is a free, open-source, self-hosted CMS platform based on the Laravel PHP Framework. A bypass of CVE-2020-15247 (fixed in 1.0.469 and 1.1.0) was discovered that has the same impact as CVE-2020-15247. An authenticated backend user with the cms.manage_pages, cms.manage_layouts, or cms.manage_partials permissions who would normally not be permitted to provide PHP code to be executed by the CMS due to cms.enableSafeMode being enabled is able to write specific Twig code to escape the Twig sandbox and execute arbitrary PHP. This is not a problem for anyone that trusts their users with those permissions to normally write & manage PHP within the CMS by not having cms.enableSafeMode enabled, but would be a problem for anyone relying on cms.enableSafeMode to ensure that users with those permissions in production do not have access to write & execute arbitrary PHP. Issue has been patched in Build 470 (v1.0.470) and v1.1.1.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2020-26231?
CVE-2020-26231 is a medium-severity vulnerability. It was published on November 23, 2020 and has a CVSS 3.1 base score of 5.2 (MEDIUM).
How severe is CVE-2020-26231?
This vulnerability has a CVSS 3.1 base score of 5.2, rated MEDIUM. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2020-26231?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2020-26231?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-26231 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related MEDIUM CVEs from 2020
View all- 6.9CVE-2019-16791
In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under
View details - 6.9CVE-2019-11999
Potential security vulnerabilities have been identified in HPE OpenCall Media Platform (OCMP) result
View details - 6.9CVE-2020-11023
In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option>
View details - 6.9CVE-2020-11022
In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sa
View details - 6.9CVE-2020-11051
In Wiki.js before 2.3.81, there is a stored XSS in the Markdown editor. An editor with write access
View details - 6.9CVE-2020-10023
The shell subsystem contains a buffer overflow, whereby an adversary with physical access to the dev
View details - 6.9CVE-2020-11038
In FreeRDP less than or equal to 2.0.0, an Integer Overflow to Buffer Overflow exists. When using /v
View details - 6.9CVE-2020-15085
In Saleor Storefront before version 2.10.3, request data used to authenticate customers was inadvert
View details - 6.9CVE-2020-7310
Privilege Escalation vulnerability in the installer in McAfee McAfee Total Protection (MTP) trial pr
View details - 6.9CVE-2020-7323
Authentication Protection Bypass vulnerability in McAfee Endpoint Security (ENS) for Windows prior t
View details - 6.9CVE-2020-5388
Dell Inspiron 15 7579 2-in-1 BIOS versions prior to 1.31.0 contain an Improper SMM communication buf
View details - 6.9CVE-2020-16988
Azure Sphere Elevation of Privilege Vulnerability
View details
