Menu

Star on GitHub · 3.3k

CVE-2020-36646

3.5 · LOW

A vulnerability classified as problematic has been found in MediaArea ZenLib up to 0.4.38.

Published Jan 7, 2023CWE-690EPSS 1.23%

Overview

CVE-2020-36646 is a low-severity vulnerability. It was published on January 7, 2023 and has a CVSS 3.1 base score of 3.5 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

Technical description

A vulnerability classified as problematic has been found in MediaArea ZenLib up to 0.4.38. This affects the function Ztring::Date_From_Seconds_1970_Local of the file Source/ZenLib/Ztring.cpp. The manipulation of the argument Value leads to unchecked return value to null pointer dereference. Upgrading to version 0.4.39 is able to address this issue. The identifier of the patch is 6475fcccd37c9cf17e0cfe263b5fe0e2e47a8408. It is recommended to upgrade the affected component. The identifier VDB-217629 was assigned to this vulnerability.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2020-36646?

CVE-2020-36646 is a low-severity vulnerability. It was published on January 7, 2023 and has a CVSS 3.1 base score of 3.5 (LOW).

How severe is CVE-2020-36646?

This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It requires local or adjacent network access to exploit. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2020-36646?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2020-36646?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2020-36646 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2020

View all
LiveWatch live →