CVE-2021-21234
7.7 · HIGHspring-boot-actuator-logview in a library that adds a simple logfile viewer as spring boot actuator endpoint.
Overview
CVE-2021-21234 is a high-severity vulnerability. It was published on January 5, 2021 and has a CVSS 3.1 base score of 7.7 (HIGH).
This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
Technical description
spring-boot-actuator-logview in a library that adds a simple logfile viewer as spring boot actuator endpoint. It is maven package "eu.hinsch:spring-boot-actuator-logview". In spring-boot-actuator-logview before version 0.2.13 there is a directory traversal vulnerability. The nature of this library is to expose a log file directory via admin (spring boot actuator) HTTP endpoints. Both the filename to view and a base folder (relative to the logging folder root) can be specified via request parameters. While the filename parameter was checked to prevent directory traversal exploits (so that `filename=../somefile` would not work), the base folder parameter was not sufficiently checked, so that `filename=somefile&base=../` could access a file outside the logging base directory). The vulnerability has been patched in release 0.2.13. Any users of 0.2.12 should be able to update without any issues as there are no other changes in that release. There is no workaround to fix the vulnerability ot
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2021-21234?
CVE-2021-21234 is a high-severity vulnerability. It was published on January 5, 2021 and has a CVSS 3.1 base score of 7.7 (HIGH).
How severe is CVE-2021-21234?
This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2021-21234?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2021-21234?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2021-21234 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related HIGH CVEs from 2021
View all- 8.9CVE-2021-21388
systeminformation is an open source system and OS information library for node.js. A command injecti
View details - 8.9CVE-2021-35213
An Improper Access Control Privilege Escalation Vulnerability was discovered in the User Setting of
View details - 8.9CVE-2021-35212
An SQL injection Privilege Escalation Vulnerability was discovered in the Orion Platform reported by
View details - 8.9CVE-2021-35215
Insecure deserialization leading to Remote Code Execution was detected in the Orion Platform version
View details - 8.9CVE-2021-35216
Insecure Deserialization of untrusted data remote code execution vulnerability was discovered in Pat
View details - 8.9CVE-2021-35218
Deserialization of Untrusted Data in the Web Console Chart Endpoint can lead to remote code executio
View details - 8.9CVE-2021-35217
Insecure Deseralization of untrusted data remote code execution vulnerability was discovered in Patc
View details - 8.9CVE-2021-38162
SAP Web Dispatcher versions - 7.49, 7.53, 7.77, 7.81, KRNL64NUC - 7.22, 7.22EXT, 7.49, KRNL64UC -7.2
View details - 8.8CVE-2021-21495
MK-AUTH through 19.01 K4.9 allows CSRF for password changes via the central/executar_central.php?aca
View details - 8.8CVE-2020-4917
IBM Cloud Pak System 2.3 is vulnerable to cross-site request forgery which could allow an attacker t
View details - 8.8CVE-2020-4942
IBM Curam Social Program Management 7.0.9 and 7.0.11 is vulnerable to cross-site request forgery whi
View details - 8.8CVE-2020-36158
mwifiex_cmd_802_11_ad_hoc_start in drivers/net/wireless/marvell/mwifiex/join.c in the Linux kernel t
View details
