CVE-2021-39228
6.5 · MEDIUMTremor is an event processing system for unstructured data.
Overview
CVE-2021-39228 is a medium-severity vulnerability. It was published on September 17, 2021 and has a CVSS 3.1 base score of 6.5 (MEDIUM).
This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
Technical description
Tremor is an event processing system for unstructured data. A vulnerability exists between versions 0.7.2 and 0.11.6. This vulnerability is a memory safety Issue when using `patch` or `merge` on `state` and assign the result back to `state`. In this case, affected versions of Tremor and the tremor-script crate maintains references to memory that might have been freed already. And these memory regions can be accessed by retrieving the `state`, e.g. send it over TCP or HTTP. This requires the Tremor server (or any other program using tremor-script) to execute a tremor-script script that uses the mentioned language construct. The issue has been patched in version 0.11.6 by removing the optimization and always cloning the target expression of a Merge or Patch. If an upgrade is not possible, a possible workaround is to avoid the optimization by introducing a temporary variable and not immediately reassigning to `state`.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2021-39228?
CVE-2021-39228 is a medium-severity vulnerability. It was published on September 17, 2021 and has a CVSS 3.1 base score of 6.5 (MEDIUM).
How severe is CVE-2021-39228?
This vulnerability has a CVSS 3.1 base score of 6.5, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
How do I fix or remediate CVE-2021-39228?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2021-39228?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2021-39228 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related MEDIUM CVEs from 2021
View all- 6.9CVE-2020-8101
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in
View details - 6.9CVE-2021-21332
Synapse is a Matrix reference homeserver written in python (pypi package matrix-synapse). Matrix is
View details - 6.9CVE-2020-13603
Integer Overflow in memory allocating functions. Zephyr versions >= 1.14.2, >= 2.4.0 contain Integer
View details - 6.9CVE-2021-28556
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected
View details - 6.9CVE-2021-38517
Certain NETGEAR devices are affected by out-of-bounds reads and writes. This affects R6400 before 1.
View details - 6.9CVE-2021-38523
NETGEAR R6400 devices before 1.0.1.70 are affected by a stack-based buffer overflow by an authentica
View details - 6.9CVE-2021-37699
Next.js is an open source website development framework to be used with the React library. In affect
View details - 6.9CVE-2021-36841
Authenticated Stored Cross-Site Scripting (XSS) vulnerability in YITH Maintenance Mode (WordPress pl
View details - 6.9CVE-2021-36845
Multiple Authenticated Stored Cross-Site Scripting (XSS) vulnerabilities in YITH Maintenance Mode (W
View details - 6.9CVE-2021-38400
An attacker with physical access to Boston Scientific Zoom Latitude Model 3120 can remove the hard d
View details - 6.9CVE-2021-41174
Grafana is an open-source platform for monitoring and observability. In affected versions if an atta
View details - 6.9CVE-2021-34357
A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running QmailAgen
View details
