CVE-2022-24851
8.1 · HIGHLDAP Account Manager (LAM) is an open source web frontend for managing entries stored in an LDAP directory.
Overview
CVE-2022-24851 is a high-severity vulnerability. It was published on April 15, 2022 and has a CVSS 3.1 base score of 8.1 (HIGH).
This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
Technical description
LDAP Account Manager (LAM) is an open source web frontend for managing entries stored in an LDAP directory. The profile editor tool has an edit profile functionality, the parameters on this page are not properly sanitized and hence leads to stored XSS attacks. An authenticated user can store XSS payloads in the profiles, which gets triggered when any other user try to access the edit profile page. The pdf editor tool has an edit pdf profile functionality, the logoFile parameter in it is not properly sanitized and an user can enter relative paths like ../../../../../../../../../../../../../usr/share/icons/hicolor/48x48/apps/gvim.png via tools like burpsuite. Later when a pdf is exported using the edited profile the pdf icon has the image on that path(if image is present). Both issues require an attacker to be able to login to LAM admin interface. The issue is fixed in version 7.9.1.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2022-24851?
CVE-2022-24851 is a high-severity vulnerability. It was published on April 15, 2022 and has a CVSS 3.1 base score of 8.1 (HIGH).
How severe is CVE-2022-24851?
This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2022-24851?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2022-24851?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-24851 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related HIGH CVEs from 2022
View all- 8.9CVE-2022-39824
Server-side JavaScript injection in Appsmith through 1.7.14 allows remote attackers to execute arbit
View details - 8.9CVE-2022-36094
XWiki Platform Web Parent POM contains Web resources for the XWiki platform, a generic wiki platform
View details - 8.9CVE-2022-36096
The XWiki Platform Index UI is an Index of all pages, attachments, orphans and deleted pages and att
View details - 8.9CVE-2022-36097
XWiki Platform Attachment UI provides a macro to easily upload and select attachments for XWiki Plat
View details - 8.9CVE-2022-36098
XWiki Platform Mentions UI is a user interface for mentioning users in wiki content for XWiki Platfo
View details - 8.9CVE-2022-39356
Discourse is a platform for community discussion. Users who receive an invitation link that is not s
View details - 8.9CVE-2022-44724
The Handy Tip macro in Stiltsoft Handy Macros for Confluence Server/Data Center 3.x before 3.5.5 all
View details - 8.9CVE-2022-29580
There exists a path traversal vulnerability in the Android Google Search app. This is caused by the
View details - 8.8CVE-2021-45960
In Expat (aka libexpat) before 2.4.3, a left shift by 29 (or more) places in the storeAtts function
View details - 8.8CVE-2021-25994
In Userfrosting, versions v0.3.1 to v4.6.2 are vulnerable to Host Header Injection. By luring a vict
View details - 8.8CVE-2021-25030
The Events Made Easy WordPress plugin before 2.2.36 does not sanitise and escape the search_text par
View details - 8.8CVE-2021-43852
OroPlatform is a PHP Business Application Platform. In affected versions by sending a specially craf
View details
