CVE-2022-39367
8.6 · HIGHQTIWorks is a software suite for standards-based assessment delivery.
Overview
CVE-2022-39367 is a high-severity vulnerability. It was published on October 28, 2022 and has a CVSS 3.1 base score of 8.6 (HIGH).
This vulnerability has a CVSS 3.1 base score of 8.6, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
Technical description
QTIWorks is a software suite for standards-based assessment delivery. Prior to version 1.0-beta15, the QTIWorks Engine allows users to upload QTI content packages as ZIP files. The ZIP handling code does not sufficiently check the paths of files contained within ZIP files, so can insert files into other locations in the filesystem if they are writable by the process running the QTIWorks Engine. In extreme cases, this could allow anonymous users to change files in arbitrary locations in the filesystem. In normal QTIWorks Engine deployments, the impact is somewhat reduced because the default QTIWorks configuration does not enable the public demo functionality, so ZIP files can only be uploaded by users with "instructor" privileges. This vulnerability is fixed in version 1.0-beta15. There are no database configuration changes required when upgrading to this version. No known workarounds for this issue exist.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
References
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2022-39367?
CVE-2022-39367 is a high-severity vulnerability. It was published on October 28, 2022 and has a CVSS 3.1 base score of 8.6 (HIGH).
How severe is CVE-2022-39367?
This vulnerability has a CVSS 3.1 base score of 8.6, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.
How do I fix or remediate CVE-2022-39367?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2022-39367?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-39367 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related HIGH CVEs from 2022
View all- 8.9CVE-2022-39824
Server-side JavaScript injection in Appsmith through 1.7.14 allows remote attackers to execute arbit
View details - 8.9CVE-2022-36094
XWiki Platform Web Parent POM contains Web resources for the XWiki platform, a generic wiki platform
View details - 8.9CVE-2022-36096
The XWiki Platform Index UI is an Index of all pages, attachments, orphans and deleted pages and att
View details - 8.9CVE-2022-36097
XWiki Platform Attachment UI provides a macro to easily upload and select attachments for XWiki Plat
View details - 8.9CVE-2022-36098
XWiki Platform Mentions UI is a user interface for mentioning users in wiki content for XWiki Platfo
View details - 8.9CVE-2022-39356
Discourse is a platform for community discussion. Users who receive an invitation link that is not s
View details - 8.9CVE-2022-44724
The Handy Tip macro in Stiltsoft Handy Macros for Confluence Server/Data Center 3.x before 3.5.5 all
View details - 8.9CVE-2022-29580
There exists a path traversal vulnerability in the Android Google Search app. This is caused by the
View details - 8.8CVE-2021-45960
In Expat (aka libexpat) before 2.4.3, a left shift by 29 (or more) places in the storeAtts function
View details - 8.8CVE-2021-25994
In Userfrosting, versions v0.3.1 to v4.6.2 are vulnerable to Host Header Injection. By luring a vict
View details - 8.8CVE-2021-25030
The Events Made Easy WordPress plugin before 2.2.36 does not sanitise and escape the search_text par
View details - 8.8CVE-2021-43852
OroPlatform is a PHP Business Application Platform. In affected versions by sending a specially craf
View details
