Menu

Star on GitHub · 3.3k

CVE-2022-4064

3.7 · LOW

A vulnerability was found in Dalli up to 3.2.2.

Published Nov 19, 2022CWE-74EPSS 1.37%

Overview

CVE-2022-4064 is a low-severity vulnerability. It was published on November 19, 2022 and has a CVSS 3.1 base score of 3.7 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2022-4064?

CVE-2022-4064 is a low-severity vulnerability. It was published on November 19, 2022 and has a CVSS 3.1 base score of 3.7 (LOW).

How severe is CVE-2022-4064?

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2022-4064?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2022-4064?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2022-4064 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2022

View all
LiveWatch live →