Menu

Star on GitHub · 3.3k

CVE-2023-22457

9.0 · CRITICAL

CKEditor Integration UI adds support for editing wiki pages using CKEditor.

Published Jan 4, 2023CWE-352EPSS 19.28%

Overview

CVE-2023-22457 is a critical-severity vulnerability. It was published on January 4, 2023 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2023-22457?

CVE-2023-22457 is a critical-severity vulnerability. It was published on January 4, 2023 and has a CVSS 3.1 base score of 9.0 (CRITICAL).

How severe is CVE-2023-22457?

This vulnerability has a CVSS 3.1 base score of 9.0, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2023-22457?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2023-22457?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2023-22457 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2023

View all
LiveWatch live →