Menu

Star on GitHub · 3.3k

CVE-2023-23611

5.4 · MEDIUM

LTI Consumer XBlock implements the consumer side of the LTI specification enabling integration of third-party LTI provider tools.

Published Jan 26, 2023CWE-862EPSS 0.38%

Overview

CVE-2023-23611 is a medium-severity vulnerability. It was published on January 26, 2023 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

LTI Consumer XBlock implements the consumer side of the LTI specification enabling integration of third-party LTI provider tools. Versions 7.0.0 and above, prior to 7.2.2, are vulnerable to Missing Authorization. Any LTI tool that is integrated with on the Open edX platform can post a grade back for any LTI XBlock so long as it knows or can guess the block location for that XBlock. An LTI tool submits scores to the edX platform for line items. The code that uploads that score to the LMS grade tables determines which XBlock to upload the grades for by reading the resource_link_id field of the associated line item. The LTI tool may submit any value for the resource_link_id field, allowing a malicious LTI tool to submit scores for any LTI XBlock on the platform. The impact is a loss of integrity for LTI XBlock grades. This issue is patched in 7.2.2. No workarounds exist.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2023-23611?

CVE-2023-23611 is a medium-severity vulnerability. It was published on January 26, 2023 and has a CVSS 3.1 base score of 5.4 (MEDIUM).

How severe is CVE-2023-23611?

This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2023-23611?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2023-23611?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2023-23611 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2023

View all
LiveWatch live →