Menu

Star on GitHub · 3.3k

CVE-2023-48699

8.4 · HIGH

fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design.

Published Nov 21, 2023CWE-95EPSS 0.74%

Overview

CVE-2023-48699 is a high-severity vulnerability. It was published on November 21, 2023 and has a CVSS 3.1 base score of 8.4 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.4, rated HIGH. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

Technical description

fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function `def __locator__(self, locator_name: str)` in `page.py`. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2023-48699?

CVE-2023-48699 is a high-severity vulnerability. It was published on November 21, 2023 and has a CVSS 3.1 base score of 8.4 (HIGH).

How severe is CVE-2023-48699?

This vulnerability has a CVSS 3.1 base score of 8.4, rated HIGH. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2023-48699?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2023-48699?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2023-48699 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2023

View all
LiveWatch live →