Menu

Star on GitHub · 3.3k

CVE-2024-22202

5.7 · MEDIUM

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases.

Published Feb 5, 2024CWE-284EPSS 0.59%

Overview

CVE-2024-22202 is a medium-severity vulnerability. It was published on February 5, 2024 and has a CVSS 3.1 base score of 5.7 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. phpMyFAQ's user removal page allows an attacker to spoof another user's detail, and in turn make a compelling phishing case for removing another user's account. The front-end of this page doesn't allow changing the form details, an attacker can utilize a proxy to intercept this request and submit other data. Upon submitting this form, an email is sent to the administrator informing them that this user wants to delete their account. An administrator has no way of telling the difference between the actual user wishing to delete their account or the attacker issuing this for an account they do not control. This issue has been patched in version 3.2.5.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2024-22202?

CVE-2024-22202 is a medium-severity vulnerability. It was published on February 5, 2024 and has a CVSS 3.1 base score of 5.7 (MEDIUM).

How severe is CVE-2024-22202?

This vulnerability has a CVSS 3.1 base score of 5.7, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2024-22202?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2024-22202?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2024-22202 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2024

View all
LiveWatch live →