Menu

Star on GitHub · 3.3k

CVE-2024-27289

8.1 · HIGH

pgx is a PostgreSQL driver and toolkit for Go.

Published Mar 6, 2024CWE-89EPSS 0.85%

Overview

CVE-2024-27289 is a high-severity vulnerability. It was published on March 6, 2024 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

pgx is a PostgreSQL driver and toolkit for Go. Prior to version 4.18.2, SQL injection can occur when all of the following conditions are met: the non-default simple protocol is used; a placeholder for a numeric value must be immediately preceded by a minus; there must be a second placeholder for a string value after the first placeholder; both must be on the same line; and both parameter values must be user-controlled. The problem is resolved in v4.18.2. As a workaround, do not use the simple protocol or do not place a minus directly before a placeholder.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2024-27289?

CVE-2024-27289 is a high-severity vulnerability. It was published on March 6, 2024 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2024-27289?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2024-27289?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2024-27289?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2024-27289 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2024

View all
LiveWatch live →