Menu

Star on GitHub · 3.3k

CVE-2024-56137

6.8 · MEDIUM

MaxKB, which stands for Max Knowledge Base, is an open source knowledge base question-answering system based on a large language model and retrieval-augmented generation (RAG).

Published Jan 2, 2025CWE-78EPSS 0.81%

Overview

CVE-2024-56137 is a medium-severity vulnerability. It was published on January 2, 2025 and has a CVSS 3.1 base score of 6.8 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.8, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

MaxKB, which stands for Max Knowledge Base, is an open source knowledge base question-answering system based on a large language model and retrieval-augmented generation (RAG). Prior to version 1.9.0, a remote command execution vulnerability exists in the module of function library. The vulnerability allow privileged‌ users to execute OS command in custom scripts. The vulnerability has been fixed in v1.9.0.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2024-56137?

CVE-2024-56137 is a medium-severity vulnerability. It was published on January 2, 2025 and has a CVSS 3.1 base score of 6.8 (MEDIUM).

How severe is CVE-2024-56137?

This vulnerability has a CVSS 3.1 base score of 6.8, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2024-56137?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2024-56137?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2024-56137 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2024

View all
LiveWatch live →