Menu

Star on GitHub · 3.3k

CVE-2024-6155

6.4 · MEDIUM

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Authenticated (Subscriber+) Server-Side Request Forgery and Stored Cross Site Scripting in all versions up t…

Published Jan 9, 2025CWE-862EPSS 0.29%

Overview

CVE-2024-6155 is a medium-severity vulnerability. It was published on January 9, 2025 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Authenticated (Subscriber+) Server-Side Request Forgery and Stored Cross Site Scripting in all versions up to, and including, 9.0.0 due to a missing capability check in the greenshift_download_file_localy function, along with no SSRF protection and sanitization on uploaded SVG files. This makes it possible for authenticated attackers, with Subscriber-level access and above, to make web requests to arbitrary locations originating from the web application that can also be leveraged to download malicious SVG files containing Cross-Site Scripting payloads to the server. On Cloud-based servers, attackers could retrieve the instance metadata. The issue was partially patched in version 8.9.9 and fully patched in version 9.0.1.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2024-6155?

CVE-2024-6155 is a medium-severity vulnerability. It was published on January 9, 2025 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

How severe is CVE-2024-6155?

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2024-6155?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2024-6155?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2024-6155 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2024

View all
LiveWatch live →