Menu

Star on GitHub · 3.4k

CVE-2025-3919

6.4 · MEDIUM

The WordPress Comments Import & Export plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_settings function in all versions up to,…

Published Jun 2, 2025CWE-79EPSS 0.30%

Overview

CVE-2025-3919 is a medium-severity vulnerability. It was published on June 2, 2025 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

The WordPress Comments Import & Export plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_settings function in all versions up to, and including, 2.4.3. Additionally, the plugin fails to properly sanitize and escape FTP settings parameters.

This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts on the plugin settings page that will execute whenever an administrative user accesses an injected page.

The vulnerability was partially fixed in version 2.4.3 and fully fixed in version 2.4.4

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-3919?

CVE-2025-3919 is a medium-severity vulnerability. It was published on June 2, 2025 and has a CVSS 3.1 base score of 6.4 (MEDIUM).

How severe is CVE-2025-3919?

This vulnerability has a CVSS 3.1 base score of 6.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-3919?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-3919?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-3919 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2025

View all
LiveWatch live →