Menu

Star on GitHub · 3.3k

CVE-2025-49005

3.7 · LOW

Next.js is a React framework for building full-stack web applications.

Published Jul 3, 2025CWE-444EPSS 0.49%

Overview

CVE-2025-49005 is a low-severity vulnerability. It was published on July 3, 2025 and has a CVSS 3.1 base score of 3.7 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Next.js is a React framework for building full-stack web applications. In Next.js App Router from 15.3.0 to before 15.3.3 and Vercel CLI from 41.4.1 to 42.2.0, a cache poisoning vulnerability was found. The issue allowed page requests for HTML content to return a React Server Component (RSC) payload instead under certain conditions. When deployed to Vercel, this would only impact the browser cache, and would not lead to the CDN being poisoned. When self-hosted and deployed externally, this could lead to cache poisoning if the CDN does not properly distinguish between RSC / HTML in the cache keys. This issue has been resolved in Next.js 15.3.3.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-49005?

CVE-2025-49005 is a low-severity vulnerability. It was published on July 3, 2025 and has a CVSS 3.1 base score of 3.7 (LOW).

How severe is CVE-2025-49005?

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2025-49005?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-49005?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-49005 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2025

View all