Menu

Star on GitHub · 3.3k

CVE-2025-53528

7.6 · HIGH

Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI.

Published Jul 21, 2025CWE-79EPSS 0.26%

Overview

CVE-2025-53528 is a high-severity vulnerability. It was published on July 21, 2025 and has a CVSS 3.1 base score of 7.6 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI. In versions before 5.4.3, the version parameter of the "/docs" endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack. This XSS would notably allow an attacker to execute JavaScript code on a user's session for any application based on Cadwyn via a one-click attack. The vulnerability has been fixed in version 5.4.3.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-53528?

CVE-2025-53528 is a high-severity vulnerability. It was published on July 21, 2025 and has a CVSS 3.1 base score of 7.6 (HIGH).

How severe is CVE-2025-53528?

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2025-53528?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-53528?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-53528 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2025

View all