Menu

Star on GitHub · 3.5k

CVE-2025-53837

9.9 · CRITICAL

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc).

Published Sep 18, 2026CWE-95EPSS 1.50%

Overview

CVE-2025-53837 is a critical-severity vulnerability. It was published on September 18, 2026 and has a CVSS 3.1 base score of 9.9 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.9, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Prior to versions 14.10.2 and 15.0 RC1, any user who can edit their own user profile or any other document can execute arbitrary script macros including Groovy and Python macros that allow remote code execution including unrestricted read and write access to all wiki contents. The reason is that rendering output is included as content of HTML macros without further escaping and it is thus possible to close the HTML macro and inject script macros that are executed with programming rights. This has been patched in XWiki 14.10.2 and 15.0 RC1 by making sure that rendering output cannot close the surrounding HTML macro. A possible workaround is available. It is, in principle, possible to add escaping to all places where rendering output is used in wiki documents, but at the moment there is no list of them.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-53837?

CVE-2025-53837 is a critical-severity vulnerability. It was published on September 18, 2026 and has a CVSS 3.1 base score of 9.9 (CRITICAL).

How severe is CVE-2025-53837?

This vulnerability has a CVSS 3.1 base score of 9.9, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-53837?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-53837?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-53837 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2025

View all
CyberStrike v2 is here — more intelligence, greater reach