Menu

Star on GitHub · 3.3k

CVE-2025-58068

9.1 · CRITICAL

Eventlet is a concurrent networking library for Python.

Published Aug 29, 2025CWE-444EPSS 0.40%

Overview

CVE-2025-58068 is a critical-severity vulnerability. It was published on August 29, 2025 and has a CVSS 3.1 base score of 9.1 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.1, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-58068?

CVE-2025-58068 is a critical-severity vulnerability. It was published on August 29, 2025 and has a CVSS 3.1 base score of 9.1 (CRITICAL).

How severe is CVE-2025-58068?

This vulnerability has a CVSS 3.1 base score of 9.1, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2025-58068?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-58068?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-58068 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2025

View all
LiveWatch live →