Menu

Star on GitHub · 3.4k

CVE-2025-59424

7.3 · HIGH

LinkAce is a self-hosted archive to collect website links.

Published Sep 18, 2025CWE-79EPSS 0.35%

Overview

CVE-2025-59424 is a high-severity vulnerability. It was published on September 18, 2025 and has a CVSS 3.1 base score of 7.3 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

LinkAce is a self-hosted archive to collect website links. Prior to 2.3.1, a Stored Cross-Site Scripting (XSS) vulnerability has been identified on the /system/audit page. The application fails to properly sanitize the username field before it is rendered in the audit log. An authenticated attacker can set a malicious JavaScript payload as their username. When an action performed by this user is recorded (e.g., generate or revoke an API token), the payload is stored in the database. The script is then executed in the browser of any user, particularly administrators, who views the /system/audit page. This vulnerability is fixed in 2.3.1.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-59424?

CVE-2025-59424 is a high-severity vulnerability. It was published on September 18, 2025 and has a CVSS 3.1 base score of 7.3 (HIGH).

How severe is CVE-2025-59424?

This vulnerability has a CVSS 3.1 base score of 7.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2025-59424?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-59424?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-59424 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2025

View all
LiveWatch live →