CVE-2025-59429
5.4 · MEDIUMFreePBX is an open source GUI for managing Asterisk.
Overview
CVE-2025-59429 is a medium-severity vulnerability. It was published on October 14, 2025 and has a CVSS 3.1 base score of 5.4 (MEDIUM).
This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
Technical description
FreePBX is an open source GUI for managing Asterisk. In versions prior to 16.0.68.39 for FreePBX 16 and versions prior to 17.0.18.38 for FreePBX 17, a reflected cross-site scripting vulnerability is present on the Asterisk HTTP Status page. The Asterisk HTTP status page is exposed by FreePBX and is available by default on version 16 via any bound IP address at port 8088. By default on version 17, the binding is only to localhost IP, making it significantly less vulnerable. The vulnerability can be exploited by unauthenticated attackers to obtain cookies from logged-in users, allowing them to hijack a session of an administrative user. The theft of admin session cookies allows attackers to gain control over the FreePBX admin interface, enabling them to access sensitive data, modify system configurations, create backdoor accounts, and cause service disruption. This issue has been patched in version 16.0.68.39 for FreePBX 16 and version 17.0.18.38 for FreePBX 17.
Remediation
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2025-59429?
CVE-2025-59429 is a medium-severity vulnerability. It was published on October 14, 2025 and has a CVSS 3.1 base score of 5.4 (MEDIUM).
How severe is CVE-2025-59429?
This vulnerability has a CVSS 3.1 base score of 5.4, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2025-59429?
Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2025-59429?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-59429 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related MEDIUM CVEs from 2025
View all- 6.9CVE-2025-27370
OpenID Connect Core through 1.0 errata set 2 allows audience injection in certain situations. When t
View details - 6.9CVE-2025-27371
In certain IETF OAuth 2.0-related specifications, when the JSON Web Token Profile for OAuth 2.0 Clie
View details - 6.9CVE-2024-12136
Missing Critical Step in Authentication vulnerability in Elfatek Elektronics ANKA JPD-00028 allows A
View details - 6.9CVE-2024-7035
In version v0.3.8 of open-webui/open-webui, sensitive actions such as deleting and resetting are per
View details - 6.9CVE-2025-30168
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.
View details - 6.9CVE-2025-29988
Dell Client Platform BIOS contains a Stack-based Buffer Overflow Vulnerability. A high privileged at
View details - 6.9CVE-2025-43013
In JetBrains Toolbox App before 2.6 unencrypted credential transmission during SSH authentication wa
View details - 6.9CVE-2025-22244
VMware NSX contains a stored Cross-Site Scripting (XSS) vulnerability in the gateway firewall due to
View details - 6.9CVE-2025-53167
Authentication vulnerability in the distributed collaboration framework module Impact: Successful ex
View details - 6.9CVE-2025-42992
SAPCAR allows an attacker logged in with high privileges to create a malicious SAR archive in SAPCAR
View details - 6.9CVE-2025-43001
SAPCAR allows an attacker logged in with high privileges to override the permissions of the current
View details - 6.9CVE-2025-53621
DSpace open source software is a repository application which provides durable access to digital res
View details
