Menu

Star on GitHub · 3.4k

CVE-2025-62800

6.1 · MEDIUM

FastMCP is the standard framework for building MCP applications.

Published Oct 28, 2025CWE-79EPSS 0.28%

Overview

CVE-2025-62800 is a medium-severity vulnerability. It was published on October 28, 2025 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-62800?

CVE-2025-62800 is a medium-severity vulnerability. It was published on October 28, 2025 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

How severe is CVE-2025-62800?

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2025-62800?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-62800?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-62800 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2025

View all
LiveWatch live →