Menu

Star on GitHub · 3.3k

CVE-2025-64715

4.0 · MEDIUM

Cilium is a networking, observability, and security solution with an eBPF-based dataplane.

Published Nov 29, 2025CWE-284EPSS 0.17%

Overview

CVE-2025-64715 is a medium-severity vulnerability. It was published on November 29, 2025 and has a CVSS 3.1 base score of 4.0 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.0, rated MEDIUM. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

Technical description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.16.17, 1.17.10, and 1.18.4, CiliumNetworkPolicys which use egress.toGroups.aws.securityGroupsIds to reference AWS security group IDs that do not exist or are not attached to any network interface may unintentionally allow broader outbound access than intended by the policy authors. In such cases, the toCIDRset section of the derived policy is not generated, which means outbound traffic may be permitted to more destinations than originally intended. This issue has been patched in versions 1.16.17, 1.17.10, and 1.18.4. There are no workarounds for this issue.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-64715?

CVE-2025-64715 is a medium-severity vulnerability. It was published on November 29, 2025 and has a CVSS 3.1 base score of 4.0 (MEDIUM).

How severe is CVE-2025-64715?

This vulnerability has a CVSS 3.1 base score of 4.0, rated MEDIUM. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2025-64715?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-64715?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-64715 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2025

View all
LiveWatch live →