Menu

Star on GitHub · 3.3k

CVE-2025-66469

6.1 · MEDIUM

NiceGUI is a Python-based UI framework.

Published Dec 9, 2025CWE-79EPSS 0.27%

Overview

CVE-2025-66469 is a medium-severity vulnerability. It was published on December 9, 2025 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are vulnerable to Reflected XSS through its ui.add_css, ui.add_scss, and ui.add_sass functions. The functions lack proper sanitization or encoding for the JavaScript context they generate. An attacker can break out of the intended <style> or <script> tags by injecting closing tags (e.g., </style> or </script>), allowing for the execution of arbitrary JavaScript. This issue is fixed in version 3.4.0.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2025-66469?

CVE-2025-66469 is a medium-severity vulnerability. It was published on December 9, 2025 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

How severe is CVE-2025-66469?

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2025-66469?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2025-66469?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2025-66469 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2025

View all
LiveWatch live →