Menu

Star on GitHub · 3.4k

CVE-2026-100227

7.5 · HIGH

Improper Verification of Cryptographic Signature vulnerability in Apache CXF's JAX-RS XML Security module.

Published Oct 9, 2026apacheCWE-362EPSS 0.33%

Overview

CVE-2026-100227 is a high-severity vulnerability affecting apache cxf. It was published on October 9, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Improper Verification of Cryptographic Signature vulnerability in Apache CXF's JAX-RS XML Security module. The JAX-RS XML Signature interceptors (XmlSigInHandler, XmlSigInInterceptor and the streaming XmlSecInInterceptor) did not ensure that the XML passed to the application was covered by the signature. An attacker with any document signed by a trusted key could wrap it in unsigned content, which the application would then treat as signed.

Users are recommended to upgrade to versions 4.2.4 or 4.1.9 or 3.6.13, which fix this issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update cxf to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachecxf>= 0, < 3.6.13Affected

Frequently asked questions

What is CVE-2026-100227?

CVE-2026-100227 is a high-severity vulnerability affecting apache cxf. It was published on October 9, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-100227?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-100227?

Check the references section for vendor advisories and patches from apache. Update cxf to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-100227?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-100227 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →