Menu

Star on GitHub · 3.4k

CVE-2026-100585

8.0 · HIGH

OpenClaw (npm package `openclaw`) before 2026.7.1 fails to enforce the owner-only authorization requirement for Claude Code permission prompts delivered through the MCP channel bridge.

Published Sep 26, 2026CWE-862EPSS 0.19%

Overview

CVE-2026-100585 is a high-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 8.0 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.0, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

OpenClaw (npm package `openclaw`) before 2026.7.1 fails to enforce the owner-only authorization requirement for Claude Code permission prompts delivered through the MCP channel bridge. An authorized non-owner channel sender with channel command access can approve or deny a pending permission request intended for the owner, causing the requested action to proceed without owner consent. The practical impact depends on the pending action and the host capabilities requested by the Claude Code run. The issue is fixed in version 2026.7.1.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-100585?

CVE-2026-100585 is a high-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 8.0 (HIGH).

How severe is CVE-2026-100585?

This vulnerability has a CVSS 3.1 base score of 8.0, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-100585?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-100585?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-100585 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →