Menu

Star on GitHub · 3.4k

CVE-2026-100720

8.7 · HIGH

Froxlor 2.0.0 through 2.3.10 is vulnerable to stored cross-site scripting.

Published Sep 26, 2026CWE-79EPSS 0.21%

Overview

CVE-2026-100720 is a high-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Froxlor 2.0.0 through 2.3.10 is vulnerable to stored cross-site scripting. When a customer (the lowest-privileged authenticated role) uploads an SSL certificate for one of their own domains, the Certificates API add()/update() methods parse it with openssl_x509_parse() and store the issuer organization (issuer['O']) value verbatim without sanitization. Froxlor's table-listing renderer then emits scalar cells through Twig's `raw` filter, disabling HTML auto-escaping, so when an administrator or reseller opens Domains > SSL certificates the attacker-supplied issuer value executes as script in the privileged user's session. This crosses a privilege boundary from customer to admin and can result in full administrator account takeover; because a Froxlor admin controls webserver, DNS, and PHP configuration applied by a cron job running as root, the issue can be further escalated to command execution as root on the managed server. The issue is fixed in Froxlor 2.3.12.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-100720?

CVE-2026-100720 is a high-severity vulnerability. It was published on September 26, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

How severe is CVE-2026-100720?

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-100720?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-100720?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-100720 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →