CVE-2026-101046
3.1 · LOWFleet before 4.89.0 contains an SQL injection vulnerability in the activity list endpoints (GET /api/v1/fleet/activities and GET /api/v1/fleet/hosts/{id}/activities).
Overview
CVE-2026-101046 is a low-severity vulnerability affecting fleetdm fleet. It was published on September 27, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).
This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
Technical description
Fleet before 4.89.0 contains an SQL injection vulnerability in the activity list endpoints (GET /api/v1/fleet/activities and GET /api/v1/fleet/hosts/{id}/activities). The deprecated cursor-pagination helper appendListOptionsWithCursorToSQL interpolated the caller-supplied sort/order key into the SQL ORDER BY clause without an allowlist, so an authenticated user with read access to Activity could order results by arbitrary columns. The impact is read-only and bounded to columns on the activity_past table that are not otherwise returned in these responses (e.g. details), allowing their values to be inferred through the resulting sort order; there is no write access, privilege escalation, or reachability of node_key or other host-join columns through these endpoints. Fixed in 4.89.0, which removes the deprecated helper and passes the sort column through SanitizeColumn.
Remediation
Check the references section for vendor advisories and patches from fleetdm. Update fleet to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
Affected products
| Vendor | Product | Versions | Status |
|---|---|---|---|
| fleetdm | fleet | >= 0, < 4.89.0 | Affected |
How CyberStrike helps
Reason, not just scan
It reasons through your app's logic the way a human pentester would, so it finds flaws signature scanners miss.
Learn moreVerified findings
Every finding is proven exploitable before you see it, which cuts the false positives that bury real risk.
Learn moreAI-driven DAST and SAST
Probe running apps and read source from one engine, so issues are caught before and after they ship.
Learn moreOpen source
Read exactly how it tests and what it reports. CyberStrike is open source and in early access.
View the repo
Frequently asked questions
What is CVE-2026-101046?
CVE-2026-101046 is a low-severity vulnerability affecting fleetdm fleet. It was published on September 27, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).
How severe is CVE-2026-101046?
This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.
How do I fix or remediate CVE-2026-101046?
Check the references section for vendor advisories and patches from fleetdm. Update fleet to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.
How can CyberStrike help with CVE-2026-101046?
CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-101046 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.
Related LOW CVEs from 2026
View all- 3.9CVE-2025-31648
Improper handling of values in the microcode flow for some Intel(R) Processor Family may allow an es
View details - 3.9CVE-2026-3632
A flaw was found in libsoup, a library used by applications to send network requests. This vulnerabi
View details - 3.9CVE-2026-3633
A flaw was found in libsoup. A remote attacker, by controlling the method parameter of the `soup_mes
View details - 3.9CVE-2026-3634
A flaw was found in libsoup. An attacker controlling the value used to set the Content-Type header c
View details - 3.9CVE-2025-66037
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, feeding a crafted
View details - 3.9CVE-2025-66038
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, sc_compacttlv_fin
View details - 3.9CVE-2026-34768
Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and C
View details - 3.9CVE-2025-31974
HCL BigFix Service Management (SM) is susceptible to a Root File System Not Mounted as Read-Only. An
View details - 3.9CVE-2026-27964
FacturaScripts is an open source accounting and invoicing software. Versions 2025.7 and prior contai
View details - 3.9CVE-2026-44069
An integer underflow in the volxlate function in Netatalk 3.0.0 through 4.4.2 allows a local privile
View details - 3.9CVE-2026-30963
Capsule is a multi-tenancy and policy-based framework for Kubernetes. To defend against namespace hi
View details - 3.9CVE-2026-45642
Improper input validation in Microsoft Azure Attestation service and Device Health Attestation Servi
View details
