Menu

Star on GitHub · 3.4k

CVE-2026-101894

9.1 · CRITICAL

The decompress package for Node.js extracts archives.

Published Sep 28, 2026CWE-22EPSS 0.81%

Overview

CVE-2026-101894 is a critical-severity vulnerability. It was published on September 28, 2026 and has a CVSS 3.1 base score of 9.1 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.1, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

The decompress package for Node.js extracts archives. Prior to 10.2.2 and 11.1.4, the default decompress(input, output) API relies on lexical containment checks that do not account for the kernel following a planted symlink chain. An attacker can supply a crafted archive containing chained symlink entries so that a later entry resolves outside the output directory. This allows files outside output to be read or written, and overwriting startup scripts or configuration can lead to remote code execution. The maintained @xhmikosr/decompress package is fixed in 10.2.2 and 11.1.4, but the separately affected unmaintained decompress package remains unpatched through 4.2.1. This vulnerability results from a bypass of the incomplete hardening for CVE-2026-53486. @xhmikosr/decompress is fixed in versions 10.2.2 and 11.1.4.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-101894?

CVE-2026-101894 is a critical-severity vulnerability. It was published on September 28, 2026 and has a CVSS 3.1 base score of 9.1 (CRITICAL).

How severe is CVE-2026-101894?

This vulnerability has a CVSS 3.1 base score of 9.1, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-101894?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-101894?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-101894 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach