Menu

Star on GitHub · 3.4k

CVE-2026-102601

3.5 · LOW

Flysystem is an open source file storage library for PHP.

Published Sep 29, 2026CWE-150EPSS 0.34%

Overview

CVE-2026-102601 is a low-severity vulnerability. It was published on September 29, 2026 and has a CVSS 3.1 base score of 3.5 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Flysystem is an open source file storage library for PHP. Prior to 3.35.3, the default WhitespacePathNormalizer in src/WhitespacePathNormalizer.php used by Filesystem across adapters calls preg_match with the u modifier and treats both false and 0 as falsy. A path containing malformed UTF-8 causes PCRE to return false, so paths that also contain control characters bypass CorruptedPathDetected::forPath() in normalizePath(). Filesystem::write() can store such names and Filesystem::listContents() can return the raw ANSI escape sequences, allowing hidden or spoofed terminal file listings when an administrator displays them. This issue is fixed in version 3.35.3.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-102601?

CVE-2026-102601 is a low-severity vulnerability. It was published on September 29, 2026 and has a CVSS 3.1 base score of 3.5 (LOW).

How severe is CVE-2026-102601?

This vulnerability has a CVSS 3.1 base score of 3.5, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-102601?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-102601?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-102601 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach