Menu

Star on GitHub · 3.4k

CVE-2026-102827

8.1 · HIGH

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript.

Published Sep 29, 2026simple-git_projectCWE-77EPSS 0.58%

Overview

CVE-2026-102827 is a high-severity vulnerability affecting simple-git_project simple-git. It was published on September 29, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.

Remediation

Check the references section for vendor advisories and patches from simple-git_project. Update simple-git to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
simple-git_projectsimple-git>= 0, < 4.0.0Affected

Frequently asked questions

What is CVE-2026-102827?

CVE-2026-102827 is a high-severity vulnerability affecting simple-git_project simple-git. It was published on September 29, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2026-102827?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-102827?

Check the references section for vendor advisories and patches from simple-git_project. Update simple-git to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-102827?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-102827 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →