Menu

Star on GitHub · 3.4k

CVE-2026-105111

4.7 · MEDIUM

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Commons BCEL.

Published Oct 6, 2026CWE-79EPSS 0.25%

Overview

CVE-2026-105111 is a medium-severity vulnerability. It was published on October 6, 2026 and has a CVSS 3.1 base score of 4.7 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.7, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Commons BCEL.

This only happens when you're using Class2HTML to generate webpages for possibly-attacker-controlled class files, where Class2HTML emitters write attacker class-file strings into HTML unescaped (stored XSS in reports).

This issue affects Apache Commons BCEL: before 6.13.0.

Users are recommended to upgrade to version 6.13.0, which fixes the issue.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-105111?

CVE-2026-105111 is a medium-severity vulnerability. It was published on October 6, 2026 and has a CVSS 3.1 base score of 4.7 (MEDIUM).

How severe is CVE-2026-105111?

This vulnerability has a CVSS 3.1 base score of 4.7, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-105111?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-105111?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-105111 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →