Menu

Star on GitHub · 3.4k

CVE-2026-105742

3.7 · LOW

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem.

Published Oct 5, 2026doclingCWE-201EPSS 0.25%

Overview

CVE-2026-105742 is a low-severity vulnerability affecting docling docling. It was published on October 5, 2026 and has a CVSS 3.1 base score of 3.7 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.95.0 until 2.132.0, the HTML image resource loader in docling/backend/utils/image_resource_loader.py forwards headers configured through the HTMLBackendOptions.headers setting to every remote image URL named by an untrusted document when enable_remote_fetch=True and fetch_images=True. The loader does not restrict those credentials to the source document's origin, allowing requests that carry custom headers such as API keys and cookies to follow cross-origin redirects and expose the caller's configured credentials to a document author. The default configuration is not affected because remote fetching and configured headers are required. This issue is fixed in 2.132.0.

Remediation

Check the references section for vendor advisories and patches from docling. Update docling to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
doclingdocling>= 2.95.0, < 2.132.0Affected

Frequently asked questions

What is CVE-2026-105742?

CVE-2026-105742 is a low-severity vulnerability affecting docling docling. It was published on October 5, 2026 and has a CVSS 3.1 base score of 3.7 (LOW).

How severe is CVE-2026-105742?

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-105742?

Check the references section for vendor advisories and patches from docling. Update docling to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-105742?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-105742 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach