Menu

Star on GitHub · 3.4k

CVE-2026-105755

4.2 · MEDIUM

vLLM is an inference and serving engine for large language models.

Published Oct 5, 2026vllmCWE-639EPSS 0.20%

Overview

CVE-2026-105755 is a medium-severity vulnerability affecting vllm vllm. It was published on October 5, 2026 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

vLLM is an inference and serving engine for large language models. Prior to 0.30.0, flash late-interaction scoring at the /score and /rerank endpoints derives each worker's query_key value from the caller-controlled X-Request-Id header. A concurrent request that reuses a victim's identifier can overwrite the cached query embedding so the victim's documents are scored against the attacker's query, and shared use counters can also cause a late-interaction cache-miss error. This issue is fixed in version 0.30.0.

Remediation

Check the references section for vendor advisories and patches from vllm. Update vllm to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
vllmvllm>= 0, < 0.30.0Affected

Frequently asked questions

What is CVE-2026-105755?

CVE-2026-105755 is a medium-severity vulnerability affecting vllm vllm. It was published on October 5, 2026 and has a CVSS 3.1 base score of 4.2 (MEDIUM).

How severe is CVE-2026-105755?

This vulnerability has a CVSS 3.1 base score of 4.2, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-105755?

Check the references section for vendor advisories and patches from vllm. Update vllm to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-105755?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-105755 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →