Menu

Star on GitHub · 3.4k

CVE-2026-105856

8.3 · HIGH

Payload is a free and open source headless content management system.

Published Oct 6, 2026payloadcmsCWE-89EPSS 0.29%

Overview

CVE-2026-105856 is a high-severity vulnerability affecting payloadcms payload. It was published on October 6, 2026 and has a CVSS 3.1 base score of 8.3 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Payload is a free and open source headless content management system. Prior to 3.90.0 and 4.0.0-canary.34, an attacker with read and create or update access to a collection containing a json field or a blocks field with blocksAsJSON enabled can inject SQL through a crafted field path and operators. Collections without those fields are not affected, and richText fields are not affected. The SQLite packages are fixed in versions 3.90.0 and 4.0.0-canary.34, and the Postgres packages are fixed in version 3.73.0.

Remediation

Check the references section for vendor advisories and patches from payloadcms. Update payload to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
payloadcmspayload>= 0, < 3.90.0Affected

Frequently asked questions

What is CVE-2026-105856?

CVE-2026-105856 is a high-severity vulnerability affecting payloadcms payload. It was published on October 6, 2026 and has a CVSS 3.1 base score of 8.3 (HIGH).

How severe is CVE-2026-105856?

This vulnerability has a CVSS 3.1 base score of 8.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-105856?

Check the references section for vendor advisories and patches from payloadcms. Update payload to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-105856?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-105856 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →