Menu

Star on GitHub · 3.4k

CVE-2026-106101

3.1 · LOW

Quasar Framework is a framework for building high-performance Vue.js user interfaces.

Published Oct 6, 2026CWE-843EPSS 0.26%

Overview

CVE-2026-106101 is a low-severity vulnerability. It was published on October 6, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to 2.32.2, the openURL() utility in ui/src/utils/open-url/open-url.js trusted window.SafariViewController whenever that global existed in an iOS environment. Attacker-controlled HTML rendered by components such as QEditor can create a named SafariViewController element, causing browser named-property resolution to replace the expected native bridge object. A later openURL() call then invokes isAvailable() on the element, throws a TypeError, and disrupts external navigation, login redirects, payment redirects, and other URL-opening workflows. QSelect and QChatMessage HTML-rendering configurations can expose the same trigger when they render attacker-controlled HTML. This issue is fixed in version 2.32.2.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-106101?

CVE-2026-106101 is a low-severity vulnerability. It was published on October 6, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).

How severe is CVE-2026-106101?

This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-106101?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106101?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106101 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach