Menu

Star on GitHub · 3.4k

CVE-2026-106492

7.6 · HIGH

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-269EPSS 0.21%

Overview

CVE-2026-106492 is a high-severity vulnerability affecting linuxfoundation backstage\/backend-defaults. It was published on October 6, 2026 and has a CVSS 3.1 base score of 7.6 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 0.16.1 and 0.17.8, the @backstage/backend-defaults package is affected by improper preservation of access restrictions during service credential delegation. An external service credential configured with access restrictions (e.g., read-only) could bypass those restrictions by routing requests through plugin delegation paths. This could allow a restricted service to perform operations beyond its intended scope, including write operations on plugins it was restricted to read-only access for. This issue is fixed in versions 0.16.1 and 0.17.8.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/backend-defaults to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/backend-defaults>= 0, < 0.16.1Affected
linuxfoundationbackstage>= 0, < 1.49.6Affected

Frequently asked questions

What is CVE-2026-106492?

CVE-2026-106492 is a high-severity vulnerability affecting linuxfoundation backstage\/backend-defaults. It was published on October 6, 2026 and has a CVSS 3.1 base score of 7.6 (HIGH).

How severe is CVE-2026-106492?

This vulnerability has a CVSS 3.1 base score of 7.6, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106492?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/backend-defaults to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106492?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106492 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →