Menu

Star on GitHub · 3.4k

CVE-2026-106498

7.7 · HIGH

Backstage is an open framework for building developer portals.

Published Oct 6, 2026linuxfoundationCWE-863EPSS 0.31%

Overview

CVE-2026-106498 is a high-severity vulnerability affecting linuxfoundation backstage_plugin-catalog-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1, the @backstage/plugin-catalog-backend package is affected by improper url validation in catalog entity placeholder resolution. An authenticated Backstage user could craft a catalog entity with placeholder directives that reference resources outside the entity's source repository. Under certain configurations, this could allow access to data not intended to be available to the user. This issue is fixed in versions 3.5.1, 3.6.2, 3.7.2, 3.8.2 and 3.9.1.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage_plugin-catalog-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage_plugin-catalog-backend>= 0, < 3.5.1Affected
linuxfoundationbackstage>= 0, < 1.49.6Affected

Frequently asked questions

What is CVE-2026-106498?

CVE-2026-106498 is a high-severity vulnerability affecting linuxfoundation backstage_plugin-catalog-backend. It was published on October 6, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

How severe is CVE-2026-106498?

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106498?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage_plugin-catalog-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106498?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106498 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →