Menu

Star on GitHub · 3.4k

CVE-2026-106556

7.7 · HIGH

Backstage is an open framework for building developer portals.

Published Oct 7, 2026linuxfoundationCWE-78EPSS 0.26%

Overview

CVE-2026-106556 is a high-severity vulnerability affecting linuxfoundation backstage. It was published on October 7, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 1.14.6, the @backstage/plugin-techdocs-node package is affected by configuration bypass in techdocs mkdocs.yml sanitization. Insufficient validation of MkDocs configuration during TechDocs generation could allow an authenticated user who can register or modify documentation sources to execute arbitrary commands in the build environment. Impact is limited to resources accessible to the TechDocs backend or build container. This issue is fixed in versions 1.14.6 and 1.15.4.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage>= 0, < 1.50.5Affected
linuxfoundationbackstage_plugin-techdocs-node>= 0, < 1.14.6Affected

Frequently asked questions

What is CVE-2026-106556?

CVE-2026-106556 is a high-severity vulnerability affecting linuxfoundation backstage. It was published on October 7, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

How severe is CVE-2026-106556?

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106556?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106556?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106556 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →