Menu

Star on GitHub · 3.4k

CVE-2026-106560

7.1 · HIGH

Backstage is an open framework for building developer portals.

Published Oct 7, 2026linuxfoundationCWE-22EPSS 0.31%

Overview

CVE-2026-106560 is a high-severity vulnerability affecting linuxfoundation backstage\/plugin-scaffolder-backend-module-confluence-to-markdown. It was published on October 7, 2026 and has a CVSS 3.1 base score of 7.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper repository path validation in a scaffolder backend module. An authenticated user who can execute an affected template and control its repository file location may cause generated content to be written outside the task workspace, within locations writable by the Backstage backend process. This issue is fixed in version 0.3.25.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-scaffolder-backend-module-confluence-to-markdown to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-scaffolder-backend-module-confluence-to-markdown>= 0, < 0.3.25Affected
linuxfoundationbackstage>= 0, < 1.54.6Affected

Frequently asked questions

What is CVE-2026-106560?

CVE-2026-106560 is a high-severity vulnerability affecting linuxfoundation backstage\/plugin-scaffolder-backend-module-confluence-to-markdown. It was published on October 7, 2026 and has a CVSS 3.1 base score of 7.1 (HIGH).

How severe is CVE-2026-106560?

This vulnerability has a CVSS 3.1 base score of 7.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106560?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-scaffolder-backend-module-confluence-to-markdown to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106560?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106560 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →