Menu

Star on GitHub · 3.4k

CVE-2026-106562

4.3 · MEDIUM

Backstage is an open framework for building developer portals.

Published Oct 7, 2026linuxfoundationCWE-754EPSS 0.20%

Overview

CVE-2026-106562 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-search-backend. It was published on October 7, 2026 and has a CVSS 3.1 base score of 4.3 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 2.1.6 in @backstage/plugin-search-backend and 1.8.7 in @backstage/plugin-search-backend-module-elasticsearch, search engine permission filtering could return documents denied by policy. An authenticated Backstage user subject to a DENY policy for search document types could receive unauthorized results in deployments with permission.enabled set to true and an Elasticsearch or OpenSearch backend. This issue is fixed in @backstage/plugin-search-backend 2.1.6 and @backstage/plugin-search-backend-module-elasticsearch 1.8.7.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-search-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-search-backend>= 0, < 2.1.6Affected
linuxfoundationbackstage\/plugin-search-backend-module-elasticsearch>= 0, < 1.8.7Affected
linuxfoundationbackstage>= 0, < 1.54.1Affected

Frequently asked questions

What is CVE-2026-106562?

CVE-2026-106562 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-search-backend. It was published on October 7, 2026 and has a CVSS 3.1 base score of 4.3 (MEDIUM).

How severe is CVE-2026-106562?

This vulnerability has a CVSS 3.1 base score of 4.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106562?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-search-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106562?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106562 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →