Menu

Star on GitHub · 3.4k

CVE-2026-106563

5.3 · MEDIUM

Backstage is an open framework for building developer portals.

Published Oct 7, 2026linuxfoundationCWE-20EPSS 0.22%

Overview

CVE-2026-106563 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-kubernetes-backend. It was published on October 7, 2026 and has a CVSS 3.1 base score of 5.3 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-kubernetes-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage\/plugin-kubernetes-backend>= 0, < 0.21.8Affected
linuxfoundationbackstage>= 0, < 1.54.1Affected

Frequently asked questions

What is CVE-2026-106563?

CVE-2026-106563 is a medium-severity vulnerability affecting linuxfoundation backstage\/plugin-kubernetes-backend. It was published on October 7, 2026 and has a CVSS 3.1 base score of 5.3 (MEDIUM).

How severe is CVE-2026-106563?

This vulnerability has a CVSS 3.1 base score of 5.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-106563?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage\/plugin-kubernetes-backend to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-106563?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-106563 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →