Menu

Star on GitHub · 3.4k

CVE-2026-107318

7.4 · HIGH

@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP or HTTPS server.

Published Oct 8, 2026CWE-295EPSS 0.14%

Overview

CVE-2026-107318 is a high-severity vulnerability. It was published on October 8, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP or HTTPS server. In versions prior to 12.7.0, all of the built-in HTTPS transports override the secure default and set rejectUnauthorized to false, so the proxy does not verify the TLS certificate of the upstream even when the application points it at an https upstream in the default configuration. An on-path network attacker can therefore impersonate the configured HTTPS upstream, read the credentials and request bodies the proxy forwards, and return forged responses that the application trusts. The issue is fixed in @fastify/reply-from 12.7.0, and users should upgrade to 12.7.0 or later. As a workaround, pass an explicit rejectUnauthorized true on the transport, supply an already configured undici instance, or use the undici global agent.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-107318?

CVE-2026-107318 is a high-severity vulnerability. It was published on October 8, 2026 and has a CVSS 3.1 base score of 7.4 (HIGH).

How severe is CVE-2026-107318?

This vulnerability has a CVSS 3.1 base score of 7.4, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-107318?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-107318?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-107318 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →