Menu

Star on GitHub · 3.4k

CVE-2026-110095

3.7 · LOW

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js.

Published Oct 20, 2026CWE-41EPSS 0.29%

Overview

CVE-2026-110095 is a low-severity vulnerability. It was published on October 20, 2026 and has a CVSS 3.1 base score of 3.7 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the refere

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-110095?

CVE-2026-110095 is a low-severity vulnerability. It was published on October 20, 2026 and has a CVSS 3.1 base score of 3.7 (LOW).

How severe is CVE-2026-110095?

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-110095?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-110095?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-110095 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
LiveWatch live →